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About This Installation Guide 
This  Installation Guide offers you a complete description of how to install the IntelliTune server and 

client. 

 

Keyboard Conventions 
 

All key names are shown in capital letters. For example, the Control key is shown as CTRL. 

 

Keys are frequently used in combinations or sequences as shortcut keys. For example, SHIFT+F3 

means to hold down the SHIFT key while pressing F3. 

 

 

Mouse Conventions 
 

To Do this 

Click Point to an item, and then quickly press and release the mouse button without moving the 

mouse. 

Double-click Point to an item, and then quickly press and release the mouse button twice. 

Context-click on Windows Click the right mouse button. 

Context-click on Macintosh Hold down the CTRL key while clicking the mouse button. 

Drag Point to an item. Press and hold down the mouse button as you move the mouse to a new 

location, then release the mouse but- ton. 
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1 :Arkitex Installation and Setup 
 

1.1 System Requirements 

 

 The minimum requirements for the IntelliTune server (and for additional processing servers) and 

for  IntelliTune client are:  

 Server - Intel PC Platform 

Dual Processor 3.2 GHz  

 2 GBytes RAM or greater * 

 80+ GBytes hard disk space available  

 Operating System:  

 Windows Server 2008 R2    64-bit 

  Windows Server 2012      64-bit 

  Windows 7 Professional      32- or 64-bit  

  Windows 8 Professional     32- or 64-bit 

  *(Microsoft© recommendations at MSDN.Microsoft.com) 

 

  Client - Intel PC Platform 

1.8 GHz Pentium 4  

1 GByte RAM or greater 

1 GByte hard disk space available  

Operating System: 

Windows Server 2008 R2    32- or 64-bit 

  Windows Server 2012      64-bit 

  Windows 7 Professional      32- or 64-bit  

    Windows 8 Professional     32- or 64-bit 

 

1.2 Product Options and Security 

Intellitune uses the Electronic Licensing System and: 

 

All upgrades can be performed electronically; 

 

Supply of all additional options, such as PDF and license Renewal, can be performed electronically; 

 

Supply of trial options and upgrades can be set to expire after a certain time period or date, if required. 
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1.3 Product Options   

Product options include: 
 

Intellitune Site License 

 

This contains the functionality of one server and one client operating on the same platform. 

Two IntelliTune platforms will be able to share the same hot folder, and also be able to limit the 

number of files IntelliTune imports at any time. By setting this number low, we automatically have a 

type of load balancing. 

 

Annual license 

 

PDF processing product option. 

 

1.4 Dongle Breakdown 

Once a dongle has been in use for a few weeks, the software allows a 30-day grace period so that any 

broken dongle can be replaced without production interruption. System security is preserved so that 

no one can run two systems by alternating 

 

1.5 The IntelliTune Starter Kit 

The IntelliTune Starter Kit includes: 

 

The IntelliTune USB dongle 

A CD or DVD containing the IntelliTune installer, documentation, and End 

User License Agreement 

 

Software is protected by a combination of the hardware dongle attached to the IntelliTuneX System 

server, and a unique license file that is linked to the installed dongle. 

 

1.6 Disable Indexing Service 

 

Prior to installation of Intellitune, disable the Indexing Service under Computer Management. If the 

service is running, it will interfere with the writing of files. 

 

Go to Start 

Click   on Windows Icon  
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In the search box, type the word Services 

 

     

 

Highlight Services then click on it to open Services and Services Applications 

 

Scroll down and find Windows Search  

 

 

 

 

Right click on Windows Search 
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Right on and Select Properties 

Change Start up type to Disabled 

Change Service status to Stopped 

Click Apply then click Ok 

 

 

 

Screen should look like this 
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Close the Services Dialogue box 
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2 Pre-Requisites 
 

The following components are necessary for IntelliTune to run. These will be checked and installed 

during the installation process. They cannot be installed manually. 

 

 Java Runtime Environment – Java jre1.8.0_51 

 JBOSS updated to Wildfly 8.1 

 Database is now PostgresQL combined with Hibernate access version 9.3.4 

 ELMS Licensing Service – Version 1.13 – Manages Software Licensing 

 WIBU Dongle and WIBU Security Software – Software driver used to interface with the dongle  

 Visual C++ redistributable package – (vcredist_X86.exe)  

 Updated Visual C++ redistributable package – (vcredist_vc10_X86.exe) 
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3 Install IntelliTune and Prerequisites on 32 and 64 bit system 
 

Administrator rights are required to install IntelliTune. 

CAUTION: Your system must be connected to a network before installing and running IntelliTune, 

otherwise unpredictable results will occur. 

3.1 IntelliTune CD Contains: 

Prerequisite software for IntelliTune support. The prerequisites are installed in conjunction with the 

installer routine, install.hta and DoInstall.vbs support script IntelliTune server and server client 

IntelliTune remote client (optional, but recommended) 

3.2 IntelliTune Prerequisite Software 

 

The Registration Utility – v4701 (setup.exe), this utility is used during the licensing process. The 

executable software is located in the Registration folder on the CD.  During installation, the install 

dialog may auto-minimize to the task bar where it is accessible for completion of the install routine.  

 

Before You Begin 

 

Check the following: 

 

 You received the IntelliTune Starter Kit and attached your IntelliTune dongle. 

 

You have the Receipt Code File (RCF) for your particular installation, and the RCF has been 

preflighted. Instructions for obtaining the RCF are given in “Checkout Receipt Code”  

 

For systems with multiple network cards, enable only one. 

  

3.3 Launch the IntelliTune DVD/CD 

 

Make sure no programs are running on your system. 

 

    NOTE: The application will not work properly without a dongle. 

 

Insert the IntelliTune DVD/CD into the drive. 

Click on Intellitune 
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Click on Accept Eula 

 

 

 

At Install Type screen will display 

Select Role: Server, Processor or client 

For this install it is Server 
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Click Next to install the Prerequisites 

For each status that is Required, that Prerequisite will be installed 

Click Next 

 

 

 

From the Database pull down, the Database can be selected.   

There are three databases to select from 

     IFRA30 USA 

     IFRA26 is European   

     ICONS26 India-Far East 

 



:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 
13 of 140 

 

  

:Arkitex Enhance Intellitune  Family Installation Guide HQ - Thousand Oaks, California  

 

 

 

When the database down arrow is clicked on three databases can be selected 

The Install Location is also specified on this screen 

The Install Location can be changed 

Click Next 

 

 

 

Click Next 

Select Installation Shares 

The location of the shares can be changed 
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Click Next 

This screen will allow the user to check setup and click NEXT to install 

Changes can be made at this point by clicking BACK 

Click NEXT 
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3.4 Pre-Requisites Installation 

 

The following components are necessary for IntelliTune to run. These will be checked and installed 

during the installation procedures. Do Not manually install. 

  

1. Java Runtime Environment updated to Java jre 1.8.0_51 

2. JBOSS updated to Wildfly 8.1 

3. PostgreSQL Database 9.3.4 

4. The Database is now PostgreSQL combined with Hibernate access version 9.3.4, this is a new extra 

prerequisite. 

5. ELMS updated to Version 1.13 – Manages Software Licensing 

6. WIBU Dongle and WIBU Security Software  

7. Updated Visual C++ redistributable package – (vcredist_X86.exe)  

8. Updated Visual C++ redistributable package – (vcredist_vc10_X86.exe) 

 

Prerequisites will begin to install 
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3.5 JAVA – 64 bit 

 

1. Answer yes to install Java 64 bit 8.0.25 

 

 

 

The Java Setup – Welcome window will pop up 

To change destination folder click on the box 

Click on Install 
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Java Setup – Progress screen will display 

 

 

 

Java Setup – Progress screen after approximately three minutes 
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Java Setup – Complete screen will display 

Click on close 

The verify Java version window will display, do not use this close the window 

 

 

 

3.6 vcredist_x86.exe  

  This software installs Microsoft Visual C++ Redistributable. 

 

1. Install Microsoft Dlls 10 

Click on yes to install it now 
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Welcome to Microsoft Visual C++ 2010 x86 Redistributable Setup 

Click on I have read and accept the license terms 

Click on Install 

 

 

 

Installation is complete 

Click on Finish 

3.7 JAVA – 32 bit 

 

1. Install Java 32 bit 

Answer yes to install Java 32 bit 8.0.25 
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The Java Setup – Welcome window will pop up 

To change destination folder click on the box 

Click on Install 

 

 

 

Java Setup – Progress screen will display 

 

 

 

Java Setup – Progress screen after approximately three minutes 
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Java Setup – Complete screen will display 

Click on Close 

 

 

 

The verify Java version window will display, do not use this close the window 

 

 

 

3.8 Install the License Management Utility 

 

1. Install ELMS License 1.12.0.5 

Click on Yes to Install 
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3.9 Install the WibuKey 

 

1. WibuKey runtime kit installing 

 

 

 

Click Next 

 

 
 

Click Next 

Click Next to use the default folder 
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Click Yes to create the folder 

 

 
 

WibuKey setup 

 

 

  

 
 

Click Next to continue Setup 

 

Installation will begin copying files 
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Wibukey installation is complete 

Click Next 

 

 

 

Uncheck Yes, I want to view the Readme text now 

Leave checked if you would like to read the readme text 

Click finish 

 

 

 

 

Click Ok 
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3.10 Install the License Management Utility 

 

1. Click Next to continue 

Click Next 
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Choose Destination Location 

Click Next 

 

 

 

Service Port 

 

 

 

Click Next 

Start copying files 
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Installing please wait 

Installation status 

ELMS Licensing Service is configuring your new software installation 

This install will take approximately 5 minutes 

 

 

 

ELMS  Licensing Service installation is complete 

Click Finish 
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3.11 PostgreSQL 

PostgreSQL Database 

 

1. Install PostgreSQL Database 9.3.4 on Serer only 

2. Click yes to install 

 

 

 

3.12 Microsoft  Visual C++ 2010 x64 Redistributable 

 

1. Extracting files will display 

2. Installation will began 

 

 

 

PostgreSQL Installing 

 

 

 

Immediately following the installation of PostgreSQL Intellitune installation will begin 
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Progress Meter is displayed 

 

 

 

Progress Meter is displayed until it is 100% 

 

 

 

Intellitune shortcut can be found on the desktop 
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3.13 Installing Remote Client 

 

The Client is considered remote if it is installed on a different host computer than the server's host 

computer. 

Launch the IntelliTune DVD/CD 

 

Make sure no programs are running on your system. 

 

NOTE: The application will not work properly without a dongle. 

 

1. Insert the IntelliTune DVD/CD into the drive. 

2. Click on Intellitune 

 

 
 

Click on Accept Eula 

 

 
 

Click Next to install the Prerequisites 
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For each status that is Required, that Prerequisite will be installed 

Click Next 

At Install Type screen will display 

Select Role: Server, Processor or client 

For this install Client is selected 

 

 

 

Click Next to accept the installation file location, or click Browse to select another location 

 

 

 

The Client Summary screen will display 

Click Install or next.  The software will begin to install 
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3.14 Prerequisites 

 

1. Install Java 8.0.51 required on Server and Client 

 

 

 

Click Yes to continue installing Java 

 

 

 

Click on Install at the Welcome to Java 
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Click to close to exit Java installed successfully window 

 

 

 

Close browser to exit Verify Java Version, click the ‘x’ in the upper right corner 

 

 

 

Click on Yes to install Microsoft Dlls 10 
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Click in box, I have read and accept the license terms 

Click on Install 

 

 

 

Click Finish to complete Microsoft Dlls 10 installation 

 

 

 

Installer will start installing Intellitune Client 

 

 

 

Profiles will begin to install, window will close when installation is complete. 
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4 IntelliTune File Structure 
 

1. The IntelliTune file structure consists of a code, config and JBoss folders. 

 

 

 

 

Code Folder 

 

 
  



:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 
37 of 140 

 

  

:Arkitex Enhance Intellitune  Family Installation Guide HQ - Thousand Oaks, California  

 

Code Folder sub folders 

Fonts 

 

 

 

Input profiles  

Logs 

 

 

 

Messages 
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Named color profiles 

 

 

Config Folder Contain the properties files 

 

 
 

Archive Logs 

Archive logs is located in the miscellaneous section of Launcher Preferences  

The default is 24 hours, can be set as low as 1 hour.  Must be set before launching Intellitune. 

 

 

 

 

DB <Databases> 
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Preconfigured databases are stored here C:\Program Files\Agfa\IntelliTune\code\DB 

 

 

JBoss Folder 

 

 

 

JBoss\Wildfly-8.1.0.Final 
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5 Launching IntelliTune 
1. After installation an IntelliTune icon will appear on the desktop. 

2. Launch IntelliTune 

3. Click the IntelliTune icon. 

 

 

 

The launcher window will display 

 

 

  

 

NOTE:  If only the Client has been installed, the launcher window will only show the Client 

service. 

 

5.1 The LauncherUtils.vbs 

1. The LauncherStart.vbs script which was used to perform a time difference check at start up has 

been replaced by the LauncherUtils.vbs script which now takes commands and gets all the server 

names. It is used to perform the time difference check at start up and then gets called every 6 

minutes. Currently this is used to perform a check of the licensing logs folder and removes logs 

older than 10 days. Note the permissions of the licensing folder are not set to allow delete by 

default. 

2. The location of the Licensing log folder for Windows 7, Windows 2008 and Windows 2012 is 

located in C:\ProgramData\Agfa Graphics folder\20140925_095435_LicenseServiceLog.xml 

3. The file location for LauncherUtils.vbs script is located in  C:\Program Files\Agfa\Intellitune\code 

LauncherUtils.vbs 

4. First line of LauncherUtils.vbs is: Const TIMEDIFF_WARNING = 480 ' Warn if time difference is 

more than this value (seconds) 
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5. LauncherUtils.vbs - If the remote client’s local PC system clock is out of sync with server’s local 

time or NTP (Network Time Protocol), a pop up message is displayed to correct time difference. 
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6 Generating a Fingerprint File 
  

1. A Fingerprint file must be generated. This is an encrypted file that contains the dongle serial 

number and the unique hardware identification reference. 

  

NOTE: The remote client cannot be used to generate the FPF. Generate the FPF by using the 

local client (the client installed on the server). 

Before starting this procedure, create a folder to store all your license-related files. We advise  you 

to create a folder called Licensing info in the following location: 

 

\\Agfa\IntelliTune\SupportFiles\ 

 

The following files should be stored in this folder: 

 

„ Fingerprint File (extension *.fpf) 

„ Receipt Code File (extension *.rcf) 

„ License File (extension *.alf) 

 

The License Management Utility is used to generate clean fingerprint files, load the Arkitex IntelliTune 

license, and view license information. 

 

CAUTION: These procedures will be performed by the Agfa Customer Engineer at the 

customer’s site. 
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Product  Identifies the product that is being licensed. 

 

License Service Host Name        Name of the host where the licensing service is installed. 

 

License Service Port Port number of the host of the licensing service is installed. 

 

Type       Identifies the Fingerprint type that will be used for licensing this product. 

 

Standard: Includes a reference of all ELMS product(s) installed on this system in the 

fingerprint. 

 

Clean: Only includes the product listed under Product above in the fingerprint. 

 

Licensing Method Dongle, Platform Key, Software Key 

 

 

6.1 Software Key ELMS protection 

The ELMS LicenseService supported two methods of protection, Dongle protection and 

PlatformKey protection. The Dongle protection mechanism makes use of a piece of hardware 

attached to the USB port of the host and the PlatformKey mechanism makes use of a ‘unique’ hash key 

generated from various attributes of the host. The Dongle provides a simple method for physical 

platforms but is more difficult to use in a VM environment. It would normally require the use of a USB 

hosting box on the network and these can be susceptible to any network glitches. PlatformKey works 

well without a dongle in a VM environment but the protection mechanism has to employ 
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characteristics from the hosting environment to prevent abuse. This means that if the VM is moved 

from one host to another the Licence will go into Grace and relicensing will ultimately be required. 

In order to better support VM operation in a full manner where portability between hosts is required 

we have introduced a third option in the ELMS Licensing mechanism called SoftwareKey. This can be 

used on both physical platforms and VMs and does not rely on use of characteristics from the hosting 

platform so will continue operation unchanged if a VM is relocated. Instead it uses a reporting 

mechanism to ensure that correct licensing is being used and no duplicates are being used. This 

requires that the platform has access to the Internet via an out-g oing https connection. No inbound 

listening ports are needed so there are no extra threats being introduced. The traffic is very light and 

the continued product operation is not threatened by any failures in the connection. Sustained failure 

to communicate will result in dropping into Grace just like a dongle failure and ultimately requiring 

relicensing. 

It is the user’s responsibility with SoftwareKey protection to avoid running multiple copies of the same 

VM platform licence. The reporting mechanism will detect this and will ultimately result in all affected 

systems being placed in Grace. 
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NOTE: Platform Key is supported for software trials only. 

 

NOTE: When converting from a platform key to a dongle system, just generate a clean 

fingerprint file. The software will not need to be reinstalled. 

6.2 To generate a Fingerprint File 

1. Launch the IntelliTune application. 

 

From the Menu bar select Licensing > License Management 

 

 

 

Select Clean 

Select Platform Key 

 

NOTE: This is only valid for Arkitex IntelliTune trials. Select Clean and 

Dongle for systems with dongles. 
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Click Generate 

 

 

 

A warning message will display. Click Yes 

 

 

 

When prompted enter a file name (e.g., Customer name or Server name) and an extension of fpf (i.e., 

FT.fpf) to generate the Finger Print File. Click Save 

 

 

 

At the Fingerprint generated successfully message, click OK. 

Click the “X” in the upper right-hand corner to close the License Management Utility. 
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6.3 Load License File 

The following procedure describes how to load the license file. 

 

 

 

1. Click   Licensing > Management 

 

 

 

Select Load License File 

Locate the license file.  It will have an *.alf extension. 
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Click Open 

 

 

 

A confirm message will appear.  Click Ok 

 

 

 

To verify the license, refer to “View License Info” 
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There is a new column called “Value” from 4.1 and above 

 

1. Click the “X” in the upper right-hand corner to close the License Management Utility 

Start Tasks     

The following procedure describes how to Start Tasks. 

Select Tasks > Start All. 
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Services will start to load.  You will see messages appear on the screen 

 

 

 

6.4 Start the Client  

The following procedure describes how to start the client. 

 

1. Select Tasks > Start Client. 

 

 

The Client service will turn green when it starts 
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The logon menu will display 

 

 

 

Enter the password:  Administrator.  Click Login 

The IntelliTune Client will display 
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6.5 Closing the IntelliTune Client 

 

1. Select File > Exit from the menu bar on the Client 

 

 

 

The IntelliTune Launcher window will display.  The Client service component will be grayed out. 

 

 

 

6.6 Restart the Client 

1. Once the Client has been stopped, you can restart and login again. 

2. To restart the Client, select Tasks > Start Client. 

3. You can also use a shortcut menu to start and stop the client 

4. Left-click to select the Client icon, then right-click. A shortcut menu will display. 
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Select Start the Login screen will display, and you can login 
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7 The IntelliTune Launcher 
 

From the Intellitune Launcher you can do the following tasks: 

Set Preferences 

1. Start Tasks 

2. Perform Database Maintenance 

3. Load Licenses, Generate Fingerprint files and View License Info 

4. Install and remove ICC profiles in support of SISR (Smart Input Space Recognition) 

5. Help > About - Check the Version Level of IntelliTune 

 

 
 

7.1 Set Preferences  

Preferences controls licensing, the licensing host, and the client host. This is a detailed 

explanation of when each item is on the Preferences User Interface 

 

NOTE: The Launcher Preferences dialog can be shown at any time, but is Read Only if 

any component is running, and the OK button is grayed out to disable any editing.  

 

 

  Set Host 

1. Select File >Preferences from the Launcher menu bar. 

 

 

 

The Preferences dialog box will display 
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Preferences supports primary and secondary licensing, and J2EE server set ups, as well as selecting 

the Role and number of Processors. 

The key to understanding the first part of Launcher preferences is that a platform may be set up in one 

of 4 Roles controlled by the radio buttons. Also the configuration is designed to allow maximum 

flexibility and the freedom to use as many platforms as desired. 

 

 

 

Working from the bottom upwards starting with Role 

 Under Server checks before failover, click on client only 

Client    

 

Client only is a platform that will only be used as a client. It has no scheduled processing capability, hence 

no processors, but does need to know the J2EE server locations in order to know who to talk to and these won't 

be localhost.  Although it doesn't need the Licensing services for operation, it does need them to check on the 

Licensing state and allow the Licensing management display to operate. 
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Processing Processing is a role for a platform that is dedicated to running pure processing as extra 

capability to those available on the server platforms. It therefore has a set up for the number of processors. A 

client is actually available but is typically not used. Just like the client it needs to know the address of the 

server(s) so that it can communicate with them. These addresses would certainly not be localhost as the server 

is on a different platform. To illustrate its use I could set up a 2 server system with say 2 processors each and 

then two other pure processing platforms with 4 processors each to give me 12 processors in total (assuming I 

have the relevant number of licenses). Another potential usage is in a fail-over scenario where when the 

primary fails the number of processors available may decrease. By having another processing only platform 

they can take over the spare processor licenses that then become available. This all happens automatically. 

When a processor starts it talks to the server and the server will give it a license if one is available. If not then 

the processor is still alive and known to the scheduler but will not be given any work (as it is unlicensed). If a 

license becomes available for some reason then the scheduler will then allocate it to any known dormant 

processors which can then start work. 

 

 

 

Secondary A Secondary server is a role where there is backup server / database / filestore ready to take 

over if the primary fails. It can run a number of processors and actually has two configurations for the number 

of processor which get started. The first number (on the left) is the processors which will be used when it 

is in its normal (non-operating) role. The second 'started' number is the number that will be used if it 

ever takes over the main operation. This allows, for example, maximizing the number of processors 

during normal operation and lowering it a little during back up so there is some spare capacity for the 

scheduling work it is now doing. Note it needs the address of the servers. The Primary server won't be 

localhost as it is a remote system. The secondary server name will be used by the local processors if it fails over. 
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Primary A Primary server is a role used either as the one and only non-backed up server or as the primary 

server in a fail-over configuration. It only needs one set of processor numbers as it is started by default and in a 

fail over situation is non-operational by definition. It needs to know the name of the secondary server in a fail 

over configuration in order to know where to back up the database and files to. 

 

 

 

Note also that the number of processors for the servers can be set from 0-16. 0 means 

what it says, i.e. you do not need to run any processors on a server machine. Of course you 

need some somewhere otherwise no work gets done. A processor only machine has a 

lower limit of 1 as 0 doesn't make any sense for that role. The max number 16 is set to 

avoid people entering stupid numbers. We can actually change that 

(MaxPlatformProcessors in Launcher.properties) in case anybody has a mega platform 

with more than 16 cores. 

 

The checkbox called Allow separate task start is a convenience option. Normally you 

just do a Start All / Start Client as required. If this option is checked then you can start 

and stop each individual module by right clicking its icon. This can be useful during 

debugging or running special tests (e.g. stopping one or more processors) but there are no 

checks here so it is the user's responsibility to have sensible combinations of modules 

running.  Start All etc is still operational with this option enabled. 

 

The checkbox called No confirm dialog during close does what it says. By default (un-

clicked) if the user tries to close the system (e.g. click X) then you get a confirm dialog to 

ensure that you intended to do that.  When the box is checked there is no confirm dialog 

boxes. 
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 Under Licensing in the Primary Host field, enter the host ID. By default this is localhost 

 

 

 

Enter the primary Port 

In the Secondary Host field, enter the host ID 

Enter the Secondary Port 

 

NOTE: You can point the server client away from the local server and display a different server 

installation. Enter the IP or host look-up name of a running IntelliTune server (not the localhost). The 

client will operate fully as a remote client with the server entered in the J2EE host field. 

 

Under J2EE Server, enter the Primary Host field. By default this is localhost. 

Enter the Primary Port. 

In the Secondary Host field, enter the host ID. 

Enter the Secondary Port. 
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Start Tasks  

 

1. Tasks controls starting/stopping service components, auto start (Tasks) and start client. By 

default when Launcher is first opened, no tasks are started. 

 

 

 

7.2 Launch Service Components 

 

1. Select Tasks from the Launcher menu bar. 

2. Select Start All. 

3. The service components will begin to start, and messages will display across the screen. 

 

 

 

  



:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 
61 of 140 

 

  

:Arkitex Enhance Intellitune  Family Installation Guide HQ - Thousand Oaks, California  

 

7.3 Activating Auto Start 

1. The following procedure describes how to activate Auto Start. 

 

Steps 

 

To automatically start tasks when IntelliTune is launched, select  

Tasks, then select the Auto Start option. 

 

 

 

When the Tasks menu is displayed again, this item will display with a check mark. 

The Launcher must be restarted for this setting to work. 

 

Start Client  

1. The following procedure describes how to start the client. 

 

   Steps 

 

2. Select Tasks from the Launcher menu bar, and select Start Client. 

 

 

 

3. To stop the Client, select Tasks, and then select Stop Client 
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Stop All Service 

Components 

 

The following procedure describes how to stop all service components. 

 

Steps 

 

1. Select Tasks from the Launcher menu bar. 

2. Select Stop All. 

3. The service components will be grayed out as they are stopped. 

 

Performing Database Maintenance 

 

When all the service components have been stopped, clicking Maintenance brings up the following selections. 

 

 

 

 Remove Jobs And Logs  

  

1. Jobs and Log files will be removed if ‘yes’ is answered to the prompt.  If a check is entered in the box 

next to Reset Job and Log Numbering, job numbers will be reset to the number one. 
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2. Click ok to Jobs and Logs Removed 

 

 

 

7.4 Backup Database    

The database can be backed up to a ZIP file using the Maintenance > Backup Database menu in the Launcher 

while ITX is shutdown. This will preserve all workflow and hot folder settings.  To minimize ZIP file size, make 

a backup when there are not many jobs in the system.  This can be performed by selecting Remove Jobs and 

Logs before backing up the database 

 

Remove Jobs and Logs 

1.  Click Remove Jobs and Logs 

2. Output Database to Text File   

3. The workflow and hot folder settings will be output to a text file. The default location is the location of 

the user’s Document’s, enter a name for the file. 

 

7.5 Restore Database 

  

The database will be restored from the backup location. 

To restore a database (from a previous backup, or an Agfa supplied ZIP), use the 

Maintenance > Restore Database menu in the Launcher while IntelliTune is 

shutdown.  

 

1. Select the database name to restore 

2. Click on Open 

3. Click on box to enter a check mark if you want to Reset Job and Log Numbering 

4. Answer the prompt “yes or no” to Remove Jobs and Logs 

5. If you answered yes to the prompt, a message will display Jobs And Logs 

Removed 

6.  A database saved from one PC can be restored onto a different PC. 

 

CAUTION: The Root Folders that a user can create as an input or parent input folder are 

not restored by the DB restore action. Root Folders must be manually created and 

manually shared with all Permissions for Everyone set to Allow ON. Proofer folders are 

not created by a Restore DB maintenance action. The user must manually create Proofer 

folders and manually share Root folders with all permissions. 
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7.6 Delete Database  

The database will be deleted. 

Select Maintenance > Delete Database 

Answer Yes or No to the question “Are you sure you want to delete the database”? 

You will be prompted to backup the database prior to deletion. 

If you answer yes to the question a dialogue box will display to enter the filename 

and save it.  If you answer No the window will close 

ZIP Logs  

All logs can be backed up to a zip file. 

1. Select Maintenance > Zip Logs 

2. Enter a name in the dialogue box 

3. Click Save 

4. Logs are saved in default location but can be stored where you choose 

5. Screen capture of logs that are zipped. 

 

  

 

 

 Output Database to Text File 

 

Click Output Database to Text File. 

 

 

A Save dialog box will display. 
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66 of 140 
:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 

 

  

HQ - Thousand Oaks, California :Arkitex Enhance Intellitune  Family Installation Guide 

Choose the folder location in the Save In box and the File name for the backup. 

 

Click Save. 

 Backup Database 

 

Click Backup Database. 

A Save dialog box will display. 

 

 

 

Choose the folder location in the Save In box and the File name for the backup. 

 

Click Save 

 

 

 

Restore Database 

 

Click Restore Database. 
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An Open dialog box will display 

 

 

 

 

Choose the folder location in the Look In box and the File name of the database to restore. 

Click Open. 

 

Delete Database 

 

Select Delete Database. 

A prompt will display asking if you are sure. 

 

 

 

Click Yes 

 

A prompt displays asking if you want to backup the current database. 

 

 

 

Click Yes 

 

A Save dialog box displays 
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Select the location for the backup 

Enter filename to save 

 

Click on save 

 

ZIP Logs 

 

Click ZIP Logs. 

A Save dialog box will display. 
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Licensing    

Before using Intellitune Load the license file 

 

Load License File 

 

 

 

Click Licensing > License Management 

 

 

 

Select Load License File 

Locate the license file.  It will have an *.alf extension 
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6. Click Open 

 

 

 

7. A Confirm message will appear.  Click Ok 

8. Click the “X” n the upper right-hand corner to close the License Manager Utility 

 

Generate Clean Platform Key Fingerprint File 

1. Launch the IntelliTune  application 
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2. From the Menu bar select Licensing > License Management 

 

 

3. Select Clean 

4. Select Platform Key 

5. Click  Generate.   

6. Answer Yes to the warning question 
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7. When prompted enter a file name (e.g., Customer name or Server name) and an extension of fpf (i.e., 

FT.fpf to generate the Finger Print File.  Click Save. 

 

 

 

8. At the Fingerprint generated successfully message, click OK. 

9. Click the “X” in the upper right-hand corner to close the License Management Utility. 

 

Generate Clean Software Key Fingerprint File 

1. Launch the IntelliTune  application 
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From the Menu bar select Licensing > License Management 

 

 
 

 

Select Clean 

 

Select Software Key 

 

 Click Generate.   

 

 Answer Yes to the warning question 
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2. When prompted enter a file name (e.g., Customer name or Server name) and an extension of fpf (i.e., 

FT.fpf to generate the Finger Print File.  Click Save. 

 

 

 

3. At the Fingerprint generated successfully message, click OK. 

4. Click the “X” in the upper right-hand corner to close the License Management Utility. 
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Show License Info 

1. Select License > License Management 

2. To confirm the license information, click View License Info 

 

 

 

3. Click Close 

4. Click the “X” in the upper right-hand corner to close the License Management Utility. 
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SISR profiles are installed during the installation.   

  StartInstall script supports a facility for loading profiles from folders under a profiles folder in 

the install set. This allows the profiles to be customized for different installs without having to 

include them all in the base set. The profiles folders are specified in the Personality.properties 

file. 

 

SISR profiles can also be installed using the SISR Install and Remove menu items on the 

launcher. The relevant menu items will only be visible if a processor is installed. Only profiles 

that have been installed in the system ICC profile folder should be used. 

 

5. Select Install ICC Profile from the menu. 

 

 

  

6. Select the ICC Profile from the list. 

 

 

NOTE: Multiple selections can be made, and the user will be warned if a profile already 

exists in the destination folder. Only CMYK profiles should be selected for install. 

 

7.  Click Install 
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NOTE: It is important to manually synchronize all the profiles used on the server and all 

remote clients. If these are not present on the remote client, then the remote client will 

not display Job Edit source/result views correctly, or fail to display them at all. 

 

Remove ICC Profile 

 

1. When the Remove ICC Profile menu item is selected, the contents of the processor SISR profile folder 

will be displayed. Select profiles from the list and remove using the Remove button. 

 

2. Select Remove ICC Profile from the menu. 

 

  

 

NOTE: Multiple selections can be made for removal 

 

Select the ICC Profile to be removed. 

 

 

 

3   Click Remove. 

4   A prompt will appear asking you to confirm the removal of profiles from SISR folder. 

 

 

 

Click Yes to confirm removing the selected profile. 
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Click No to cancel. 

Click Cancel to cancel the operation. 

 

 

Restore Default SISR Profile  

 

When defined in personality.properties a third selection is displayed from the 

SISR pull down to allow Restore Default SISR profiles 

Before edit of personality.properties the pull down has two options 

 

 

 

After edit of personality.properties “Restore Default SISR profiles” is added to the menu list 

 
 

Example of personality.properties edit: 

C:\Program Files\Agfa\ITX_4.0\config\personality.properties 

Add profiles to SisrList = and separate each profile with a comma 

SisrList= ISOnewspaper26v4.icc, ISO-WebCoated.icc, ISOcoated.icc, 

Help  

1. Help displays information about the IntelliTune Launcher and Weblink when configured. 

 

Launcher Help About 

 

2. Click File > Help and select About. 

 

 

 

3. The About dialog box will display. 
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4. The version and copyright information displays. 

5.  Click OK to close the dialog box. 

Client Help About 

 

 

 

Now it is controlled by the WebLink property in the personality.proerties file. For example, 

in IntellituneX personality.properties file there is a line like WebLink=Arkitex 

Web,http://arkitex.agfa.net 
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Archive Logs Folder 
 

1. Logs will be archived when the Launcher is started up. These are zipped to an archivelogs folder every 

time the Launcher is restarted. A clean ArchiveFiles function checks the archivelogs folder and 

removes logs more than 30 days old 

 

  

 

2. Check for the log folder locations at: 

...\Program Files\Agfa\IntelliTune\code\archivelogs is a typical install location. 

There is a new option added to Intellitune for Archive Logs in Launcher Preferences.  This can 

be found in the Miscellaneous section and can be set from 0 to 960 hours. The default setting is 

24 hours. 

3. The screen capture above displays two logs created at 1:21pm and 2:21pm, the Archive Log 

hours is set to one hour. In addition to a zipped Log being archived each time the Launcher is 

started, a zipped log will be archived every hour. 

 

  

 

 



:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 
81 of 140 

 

  

:Arkitex Enhance Intellitune  Family Installation Guide HQ - Thousand Oaks, California  

 

 

 Client Only Mode 

 

1. When operating in Client Only mode, the Launcher will exhibit the following behavior: 

2. When the client is started manually, then the Launcher is automatically minimized.  

3. Task Bar 
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4. When the client is started using Auto Start Client, then the Launcher starts off minimized. 

AutoTerminate Launcher applies only to client only machines and is designed to give direct access to 

the client from the desktop icon without the launcher remaining. So when selected and if the client is 

auto-starting then the launcher is removed. 

 

 

 

5. When the client is exited and NOT in Auto Start Client mode, then the Launcher is automatically 

restored. 

6. When the client is exited and IN Auto Start Client mode, then the Launcher is  automatically closed. 

7. When the Launcher is closed with the client running, then the client is automatically closed. 

8. The Start All menu item is disabled in pure client mode. 

 

Uninstalling IntelliTune for earlier releases before 4.0 

1. Should you have to reinstall IntelliTune, some manual clean-up will be required of remaining folders. 

2. To Uninstall IntelliTuneX 

3.  Close the server Launcher to stop all processes. 

4. Go to Start > Control Panel > Add/Remove Programs. 

5. Select IntelliTune from the list. 

6. Follow the prompts to uninstall the software. 

7. Click Finish when done. 
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8. Close the Control Panel windows. 

                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

Do this for Release 4.1 and above to uninstall: 

 

1. Insert CD or browse CD for Launcher.exe click on file 

2. Click on Uninstaller 

3. Select Uninstall Location 

4. This shows a current install selector and an option to keep configuration files, which is useful if this 

folder, is to be re-used and the same set up is required.  

5. Select Build to remove 

 

 

 

6.  Click Next  

 

 

 

7. At the prompt you can answer Ok or Cancel 

8. If Ok is answered  
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9. Code and Jboss folders are removed 

10. Close application by clicking on the “X” in the right hand corner 

11. The Config folder will remain for reuse and the same set up can be used  

 

 

 

12. To remove all subfolders untick Keep Configuration data 

13. Click Next 

 

 

 

14. At the prompt you can answer Ok or Cancel 

15. If Ok is answered 
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16. Information will display  that Uninstalled Code, JBoss All. 

17. Pressing the Next button performs the operation and returns to the same screen so that multiple 

uninstalls can be done. 
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8 Registration Utility and 

8.1  ELMS Portal 

 

This chapter is intended for the IntelliTune administrator. It describes the Registration Utility, Receipt Code, 

the ELMS Portal, Preflighting, and the License File. 

 

Installing the Registration Utility 

The Registration Utility is used to upload a License Request File and communicate with thegfa licensing server. 

In this case, the system should be running Windows Server 2008, Windows 2012, Windows 7, and Windows 8. 

 

CAUTION: If the person installing the application has a full .ALF license already issued 

for the host computer, this application does not need installation. 

 

1. The Registration Utility Installer can be found on the CD in the folder: 

 

To Install the Registration Utility 

 

2. Double-click the Setup.exe file to start the Installer. 

 

 

 

3. Read the Welcome Information and click Next  
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4. Select an installation folder and click Next 

 

 

 

 

5. Confirm Installation 

6. Click Next 

7.  Installing RegistrationUtility 

8. Screen will close 

  

8.2 Checkout Receipt Code 

 

Before creating a company account on the Agfa Licensing System (ELMS), you should do the 

following: 

 

 To Checkout the Receipt Code 

1. Open your Web browser, and go to https://licensing.agfa.net. 

2. Enter your User name and Password. 
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3. Click OK. 

4. The Agfa ELM System is displayed. 

5. Click the Licensing tab. 

6. Under the Digital Warehouse Manager select Receipt Code Checkout. 

7. Locate your customer Receipt Code ID under the heading Receipt Code. 

8. Select the Receipt Code ID using the check box. 

9. Press Continue. 

10. If required, select PreFlight Selection. If not required, continue to the next step. 

11. Select Create ReceiptCode File. 

12. A file download will appear. 

13. Save this ReceiptCode File to storage. 

14. Continue to “Creating a Company Account on the ELMS Portal”  

 

Creating a Company Account on the ELMS Portal 

1. If there already is an account, the information will automatically populate the fields when the 

customer number is entered. 

2. Open your Web browser, and go to https://licensing.agfa.net. 

3. Enter your User name and Password, and click OK. 

4. The Agfa ELM System Portal is displayed.  

 

  

 

5. Click the Customer tab. 

6.  Click Add New. 

 

7. The Customer Details form displays. 
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8. Click Check to see if the Customer WebID already exists, and choose another one if necessary. 
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NOTE:  WebID: customer name_mm_yy, with mm the month, and yy the year. 

 

9. Complete the form, making sure that you enter a company e-mail address. This address will be used to 

send information on bug fixes, licensing, and new features. 

 

10. Click Submit. 

The account is created, and your Customer Ticket is displayed. 

 

11.  Receipt Code Files and PreFlighting 

Your Receipt Code File (RCF) is provided by the Digital Warehouse Manager. The Receipt Code groups 

together sales order codes for your particular installation or system upgrade. You can validate a 

Receipt Code File by preflighting it. This process: Checks up-front whether or not a license can be 

successfully generated: 

 

 for a complete system (new installation or upgrade) 

for new options on an existing configuration 

  

 If the preflight is successful, a PreFlight Information section is added to the RCF, possibly with 

warnings. If the preflight fails, then the RCF file is not updated with the PreFlight Information section. 

 

Locating and Verifying your Receipt Code File 

Make sure you have the Receipt Code File before visiting the customer site. You will need to specify 

where this file is located when you run the Registration Utility. 

  

RCFs and PreFlight Reports 

If the Digital Warehouse Manager (Agfa Sales Office) preflighted the Receipt Codes when they were 

checked out, the RCF contains the results of this validation. 

 

If there is no ‘PreFlight Information’ section in the RCF, you can perform the preflight yourself prior to 

going to the customer. 

 

To verify your RCF using a web browser 

 

1. Open the RCF in a web browser. 

2. Locate the PreFlight Information section. 

 

If this section exists and no warnings are displayed, then the file is OK. Other- wise, you must ask your 

Digital Warehouse Manager for a preflighted RCF. 

 

To verify your RCF using the Registration Utility (new installation) 
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3. Start the Registration Utility (version 4.7.0.1 or later). 

4. Select File > Open, and choose a Fingerprint File. 

5. Select File > Add, and select the RCF File. 

 

If no warnings are displayed, the RCF has already been successfully preflighted. 

 

To verify your RCF using the Registration Utility (existing installation) 

 

 In this case, the RCF already contains options for an existing configuration. 

 

6. Start the Registration Utility (version 4.6.0.1 or later). 

7. Select File > Open, and choose the latest License File for this configuration. 

8. Select File > Add, and select the RCF File. 

 

NOTE: If no warnings are displayed, the RCF has already been successfully preflighted for this 

particular configuration. 

 

Creating an IntelliTune License File 

Using the Registration Utility, merge the Fingerprint and Receipt Code File into the License Request 

File. 

 

NOTE: You should already have a Receipt Code File. You must also have the latest version of the 

Registration Utility installed  

 

To upload LRF and generate a License File 

 

1. Go to Start > All Programs > Agfa > Registration Utility. 
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2.    The Registration Utility window displays. 

  

  

 

3. Select File > Open, and browse to the location of the Fingerprint File that you just generated 

(extension *.fpf).                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

4. Click the License File in the Configuration Details to download the License File. 

5.  Click OK to save this file to disk. 

6. Select a location, and click Save. 

7. Click Close. 

 

 

Using the Registration Utility in ‘Offline’ Mode 

This section describes how to create a License Request File and upload it to the Agfa ELM System 

Portal. With the uploaded License Request File, you can then generate a License File. This 

License File will be downloaded from the Agfa ELM System Portal. 

 

To create a License Request File 

1. Start the Registration Utility. 

2.  Select File > Open, and browse to the location of the Fingerprint File that you just generated 

(extension *.fpf). 

3. Click Open. 

4. The file is listed in the Message field. 

5. Select File > Add, and browse to the location of your Receipt Code File 

6. (extension *.rcf). 

7. Click Open. 

8. A message may pop up indicating that the Receipt Code File was either not 

9. PreFlighted when it was checked out, or has some PreFlight warnings. 
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10. In this case, click Yes if you are confident that it will be OK. If you have any doubts, click 

11. No and ask for a new preflighted Receipt Code File from your Digital Warehouse Manager. 

12. The file is listed in the Message field. 

13. Select View > Customer Details. 

14. Enter the user name (WebID). 

15. Select File > Create LRF (License Request File), and browse to the folder where you want to generate 

the License Request File (extension *.lrf). 

16. Enter a filename, and click Save to generate and save the License Request File. 

17. This operation is confirmed in the Message field. 

18. Select File > Exit to close the Registration Utility. 

 

To download a License File from the Agfa ELM System Portal 

NOTE: This can only be done by an Agfa Service Engineer. 

 

1. Open your Web browser, and go to https://licensing.agfa.net/rc. 

2. Enter your User Name and Password, and click OK. 

3. Your Licensing System Portal is displayed. 

4. Click Licensing. 

5. Under the Registration Manager, select License File > Create. 

6. You are prompted to upload the License Request File. 

7.  Click Browse, and locate your License Request File. 

8. Select the License Request File, and click Open. 

 

NOTE: The License Request File has an *.lrf extension. 

 

9. Click Create License File. 

10. If the License File is successfully generated, you will see the following screen briefly. 

11. The download window for the IntelliTune License File appears automatically. 

12. Click Save to proceed. 

13. Select a location that can be accessed by the IntelliTune Client. 

14. You should save your License File(s) in: ...\Agfa\IntelliTune\SupportFiles\Licensing info 

15. Click Save. 

16. If the License downloading fails due to network problems, use the My Recent 

17. License Files link under the Registration Manager. 

 

Backup Licensing 

IntelliTune uses the standard Agfa ELMS based Licensing service. When the service is available, the control of 

all product options are managed by the service. If the dongle protecting the licence fails, the service manages 

this by operating in a Grace period. There is no properly managed process for handling failures of the Licensing 

service itself. This becomes particularly critical when multiple platform instances of the product share a 
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common Licensing service. If this fails, then potentially all instances will fail at the same time. Currently this is 

managed by a local short-term pseudo-grace mode of operation. Automatic fail- over to an enhanced pseudo-

grace service is explained. 

 

Enhanced Backup Licensing 

Enhanced Backup Licensing is used in a multi-platform environment. IntelliTune uses the standard Agfa ELMS 

based Licensing service. When the service is available the control of all the product options are managed by the 

service. If the dongle protecting the license fails, the service manages this by operating in a Grace period. 

 

The Enhanced Backup Licensing is designed to manage failures of the Licensing service itself.  

 

LicenseServiceLog.xml 

The installer implements logging as part of the prerequisites installed. The log file is LicenseServiceLog.xml 

and is located at: 

  

Windows 7 and Windows 2008 

 

C:\ProgramData\Agfa Graphics 

 

Windows 2008 

 

C:\Documents and Settings\All Users\Application Data\Agfa Graphics 

 

LicenseServiceLog.xml can be opened with Internet Explorer and will use the associated style sheet log.xsl to 

give a tabular log view. 
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9 Primary and Secondary Servers 
 

Configuring the Servers 
 

Primary/Secondary 
 

 Primary/Secondary Licensing and Primary/Secondary Server are two different and independent features. 

… Primary/Secondary Licensing can be used without using Primary Secondary Servers. 

… Primary/Secondary Servers can be used without Primary/Secondary Licensing. 

… Primary and Secondary Licensing and Servers can be used together. 

 

Primary/Secondary Licensing 
 

This is a feature to provide a back up mechanism for Licensing where one or more servers are 

controlled from one Licensing alf file. It is a more controlled replacement for the previous pseudo-

grace functionality. 

 

Two Licensing platforms (Primary/Secondary) share the same Licensing information and exchange 

information to provide a non-stop Licensing service in the event of one platform failure. 

  

Single Licensing with Pseudo-Grace 
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 Single Licensing with Pseudo-Grace 

     

 

    Server A             Server B 
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Primary Secondary Licensing 
 

 

 

Primary Secondary Licensing 

     

 

       Server A          Server B 

 

1. Each independent server checks out its Licenses from the Primary Licensing service. 

2.  Primary and Secondary Licensing machines exchange information so they each know what Licenses 

3. are checked out. 
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4.  If the Primary Licensing service becomes unavailable, the schedulers automatically switch to the 

5. Secondary Licensing service and continue un- interrupted operation. 

6. Even if the Primary Licensing is not available at start up, then the 

7. Secondary Licensing will be used. 

8.  Unless both Primary and Secondary Licensing services are running AND can communicate with each 

9. Other then the Licensing is graced until normal dual operation is restored. 

10. Any number of servers can share the same Primary/Secondary Licensing set up. 

 

NOTE: Normally the Primary and Secondary Licensing should be on the same subnet to 

communicate. 

 

Fingerprinting 

 

1. Fingerprint is still controlled from one License management operation; but two fingerprints are 

2. requested in sequence. 

3.  If using a dongled fingerprint, the dongle should be on the Primary server. 

4. The secondary fingerprint is automatically made PKP. 

5. The Fingerprints are combined in the Registration utility. 

 

Loading 

 

1. Loading is single alf constructed, which contains both fingerprints and one set of 

2. Licenses. 

3. Licensing management is loaded on one platform, but automatically loaded onto both Licensing 

services. 

4. An alternative server set up to provide: 

5. Centralized load balancing 

6.  A single database for client logging and centralized job tracking 

7.  Automated fail-over to a Secondary server 

8.  Two Server Licenses needed to License a primary/secondary pair 

 

 Platforms can now be set up in 1 of 4 roles: 

 

 Primary 

 

1. Active JBOSS, Scheduler  

2. Optional Processors and client 

  

Secondary 
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3. Back up JBOSS, Scheduler  

4. Optional Processors and client 

5. Processing 

6. Processing units and optional client 

7. Pure client 

 

„    Processors are now properly licensed. Default is 4 per server bought. 

 

Primary Secondary Servers - Primary Active 
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Primary Secondary Servers - Setup 

 

 

Server A        Server B 

  

 

1. The Primary Server normally runs the Database J2EE, Scheduler and some processors, backs up files, 

database /config to secondary periodically (default 5 minutes). 

2. The Secondary normally runs processors, which just connect to the primary machine. 

3. If the Secondary Launcher detects the Primary has failed, it initiates a fail-over automatically. 

4. The Secondary starts up its J2EE database / scheduler.  

5. The Processors and clients automatically find the working server (Primary/Secondary) and 

autonomously follow any fail-over operation. 
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Primary Secondary Servers - Failed Over 

 

  

 

6. Normally the Primary platform would fail completely and the Secondary would continue with its own 

resources. 

7. Detection of failure and the failover operation can take 4 to 5 minutes. 

8. If pure Processing platforms are defined, they will connect automatically to the active server whether 

it be the Primary or the Secondary. 

9. Most times the Primary/Secondary Server systems will be set up as the Primary/ Secondary Licensing 

systems as well. 

  

 

Primary Secondary Servers - Primary Active 
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Primary Secondary Servers - Setup 

 

 

Server A      Server B     Processor C 

 

 

It is best to make sure that the number of processors on a server platform is less than the number of CPU cores 

to make sure that the scheduler has some spare capacity; e.g., Quad core set up for 2 or 3 processors. 

 

„ Currently a scheduler becomes a bottleneck when more then 8 processors are active across all the platforms. 

 

„ If more than 8 processors are wanted for high throughput, it is best to use separate servers. 
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9.1 Configuring Producer and Intellitune with PDF option 

 Method 1 - Producer 

 

  

 

1. „ Producer equally shares work to multiple Servers. 

2. „ Well controlled load sharing is achieve via XML feedback. 

3. „ There is some degree of centralized tracking at Producer. 

4. „ Clients have to log on to each server for detailed tracking. 

5. „ This method is highly scaleable, and needs a Producer system. 

1.  

2.  

 Method 2 - Folder Sharing 

 

  

 

6. „ The Servers monitor common hot folders. 
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7. „ Set small queue 

8.  … ProcessQueueDepth=Processors + 2  (change can be made in System Preferences) 

 

 

 

9. … Servers "purge" jobs that get picked up by other servers 

10. „ Clients have to log on to each server for detailed tracking. 

11. „ No other products are needed. 

12. „ Do not use for more than 3 servers. 

  

 

Method 3 - Single Server 

 

  

  

 

13. „ A single server monitors hot folders and schedules jobs. 

14. „ Secondary and/ or Processor platforms add processors that share the work. 

15. „ Clients log on to the one server for full central detailed tracking. 

  



:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 
105 of 

140 
 

  

:Arkitex Enhance Intellitune  Family Installation Guide HQ - Thousand Oaks, California  

 

  

Hotfolders Storage Areas  

 

  

Two basic techniques in Primary/Secondary. 

 

16. „ Put on the server and let them automatically swap during fail-over. 

17. … This is easy to set up. 

18. … This needs data external feeds and collection to be aware of the dual system. Or use a proxy set up. 

 

Out on a secure network storage point (SAN) 

 

… This needs external storage. 

 

… This can be very secure. 

 

… This minimizes swap over complicity. 

 

Hot folders defined as local to Server are stored as localhost in the database and translated to the physical 

machine when read. 

  

Hints and Tips 

Primary Secondary Licensing across sub-nets 

 

… Normally the servers auto-discover their partners by broadcast search. 

 

This does not work across sub-nets without special router configuration. 

This can be overridden by putting the remotePartnerIP:port number where the port number is 9000 in 

the LicenseService_Public.Config.xml file explicitly. 

 

remotePartner="192.168.1.2:9000" 
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Primary Server  

On the Primary server, do the following: 

 

Configure Preferences 

 

 

1. In the IntelliTune Launcher select File > Preferences. 

2. Enter the Primary host name and secondary host name, in Licensing section, and in the J2EE section. 

3. Enter the Role, click on Primary 

4. Click OK to exit the window. 
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Secondary Server  

On the Secondary server, do the following: 

 

Configure Preferences 

 

 

1. In IntelliTune Launcher go to File > Preferences. 

2. Enter the Primary host name and secondary host name, in Licensing section, and in the J2EE section. 

3. Enter the Role, click on Secondary 

4. Click OK to exit the window. 
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Licensing 

For licensing, do the following: 

 

Generate Clean Fingerprint 

Do the following on the Primary Server 

1. Start the IntelliTune Launcher, and go to Licensing > License Management. 

 

 

 

NOTE: The dialog will display the Product Version, Licensing Service 1 information, and Licensing Service 2 

information. 

 

2. In the Fingerprint Type, select Clean. 

3. In Licensing Method, select Dongle. 

4. Click Generate.  
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5. In the Save Primary Fingerprint File dialog, create a file name for the fingerprint (FPF) in the File 

Name field. 

6. Save to an accessible location, such as My Documents. 

 

 

 

7.  The information window will display the status that the FPF was created successfully. Click OK. 

8. The Save Secondary Fingerprint File dialog will display. 
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9. Create a file name for the FPF in the File Name field, and save to an accessible location. 

  

 

10. The information window will display the status that the FPF was created successfully. 

11. Close the information window, click Ok. 

 

Registration Utility 

1. Open the Registration Utility 4801. 

 

 

 

2. In the Registration Utility 4801 or higher, select File > Open FPF. 

3. Select the file name for the Primary server. 

4. Select the Server FPF, and click on Open, if needed. 

 

 

 

5. The Information window displays the option for working in a failover environment (PKP). Select Yes. 

6. The dialog for selecting the Secondary Server FPF file name is displayed. 

7. Select the file name, and click on Open, if needed. 

8. In the File Menu, select Add receipt code to open the dialog. 
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9. In the Open RCF dialog, browse to the location of the Receipt Code File (RCF), and click the RCF file 

name. Click Open, if needed. 

 

10. The Licensing dialog is displayed. 

11. If the RCF is a preflight type, you can choose Yes to continue. 

12. If the RCF is not a preflight type, you can also choose Yes to continue. 

13. Choose No if you want to stop the process and arrange for a preflight RCF type. 

14. You may add the Web ID, if needed. 

15. To add the Web ID, select View > Customer Details. 

 

  

 

16. Select File > Upload License LRF. The License Server Login window will display. 

 

17. Enter the login information, and click OK. You will connect to the license server. 

18. The License Request File (LRF) is uploaded to the licensing server. A 

19. status window will display. 

20. If the LRF upload succeeded, the License File (ALF) license file will be available for download. The ALF 

file can be saved with an optional file name of your choosing. A default ALF file name is also available. 

21. Download the ALF file to an accessible location on the local computer. (For example, My Documents is 

suitable for storing the ALF license file.) 

22. If the LRF upload failed, note the status window error message and correct any problems. FPF 

generation or RCF integrity may cause issues with LRF uploading. 

 

On the Primary server, do the following: 

 

1. Start the IntelliTune Launcher, and go to Licensing > License Management. 

2. Select Load License File. 
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3. In the Load License File dialog, browse to and select the ALF file name.Click Open, if needed. 

4. The ALF license is loaded on the Primary and Secondary server. The dialogue box will display for 

Primary then Secondary.  

 

 

5. Click Ok to License file loaded successfully 

6. To check the license status, start the Launcher processes on the Primary and Secondary server. 

7.  Select Licensing > License Management. Click on View License Info. The dialog displayed is a view 

of the licensing version, Total Count for options, Checked out count by the license, expiration date and 

Value. 

  

 

Servers Status 

 

The IntelliTune Primary and Secondary servers are designated and connected to the network. 

 

Both servers are installed with IntelliTune 5.0. 
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The IntelliTune Primary and Secondary servers are installed with IntelliTune, configured, and 

connected to the network. 

 

Primary server configuration - Enter this information before configuring the Secondary server. In the 

IntelliTune Launcher go to File > Preferences, and enter the primary and secondary host IP or 

hostname in the Licensing section, and in the J2EE section. 

 

Secondary server configuration - In the IntelliTune Launcher go to File > Preferences, enter the 

secondary host IP or hostname in the Licensing section, and in the J2EE section. (The Primary 

Licensing information is already applied. Enter information if it is not already applied.) Click OK to 

exit the window. You must restart the IntelliTune Launcher to apply the configuration settings. 

 

A dongle is installed on the Primary server. 

 

The license for Primary and Secondary servers is installed. The license is installed on the Primary 

server AFTER the primary and secondary are both configured. The license is automatically copied 

through the network to the secondary server. No action to install license is needed on the secondary 

server. See section for Installing license. 

 

The IntelliTune Launcher window and processes of the Primary server are running. 

 

The Launcher window of the Secondary server is running. 

 

The Processes of the Secondary server can be running or not running. If processes are running, the 

Secondary server will share in the job processing of a portion of the jobs input to the Primary server. 

 

Assure that file synchronization is occurring between the Primary and Secondary server. To verify, 

check the Primary Server Scheduler log. It will display synchronization log entries that identify the 

Primary and Secondary server. 

  

If the Primary and Secondary servers have been in operation as stand-alone servers, a license that 

supports primary and secondary operation can be obtained and installed. The new license will 

supersede the previous license. 

 

Failover from Primary to the Secondary server 

 If the Secondary server cannot contact the Primary server through the network, the Secondary server 

will begin the failover process. The Secondary server will assume the role as Primary server upon 

completion of the automatic shutdown and restart process. 

 

The Secondary server will operate with the configuration that has been previ- ously set. The Secondary 

server will not "inherit" image processors from the Primary server. For example, if the Primary server 

has 4 image processors, and the Secondary server is configured for 2 processors, the Secondary server 

will operate with 2 processors when it assumes the role as the Primary server. 
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When the Primary server resumes operation, the secondary server can return to the role of secondary 

server. A manual shutdown of the Secondary server is required to accomplish this. 
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Secondary Server Operation 

The Secondary server can run with image processes started and share the job processing workload of 

the Primary server. In this scenario, the Secondary server has not assumed the role of Primary server, 

but is in a stand-by status. 

 

When the Primary server fails, the Secondary server automatically restarts in the configuration of a 

Primary server. Automatic restarting of the Secondary server Launcher occurs if Launcher processes 

are running or not running. 

 

The automatic file synchronization between the Primary and Secondary server will maintain the 

configuration of the Secondary server. Workflows, input points, and storage locations are identical on 

both servers. However, the Secondary server is normally running on a different host system. When the 

Secondary server takes over the role of the Primary server, the network workflow will need to be 

adjusted for the new host system. Applications may need to redirect jobs to inputs on the new host, 

and completed jobs are also relocated to the new host. 

  

Primary Server Licensing Considerations 

 If the license of the Primary server expires, the Primary and the Secondary server will enter a grace 

period. The IntelliTune Launcher and the client will display this status. Installing a valid license will 

restore normal operation to both servers. 

  

If the Primary server loses network contact with the licensing service of the Secondary server, the 

Primary and Secondary server will enter a grace period. Normal operation of both servers will resume 

when network contact is restored. 

 

If the Secondary server loses network contact with the licensing service of the Primary server, the 

Primary and Secondary server will enter a grace period. Both servers will resume normal operations 

when network contact is restored. 

 

Restoring the Primary Server After Failure 

 Start the Primary server Launcher, and install a valid license, if needed. Use the Maintenance menu 

selection to "Remove jobs and logs". Check the IntelliTune share folder (typically 

c:\itx_filestore\_stable), and manually delete orphaned jobs found there. 

 

Let all local job processing finish on the Secondary server before starting processes on the partner 

Primary server. 

 

OR 

 

As an alternate step, the Primary server should be configured as a stand-alone server if the Secondary 

server is processing jobs. After the Secondary server finishes job processing, the Primary server can be 
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configured with the Secondary server settings, and the Secondary server can then be restarted. When 

the Secondary server restarts, it will resume operating in the Secondary server role. 

  

 

 

Manual Failover operation 

Manual failover is achieved in 2 stages. 

 

1. First if the Master platform is still available, then the user should place it in the Secondary Server 

Backup platform mode if a role swap is required, or shut it down if it should no longer participate in 

the system. In both cases the scheduler, J2EE, and scanner functions should all cease to be active and 

any connections from clients, and processors should be dropped. Processors are allowed to remain 

active on this platform when making this role change, although they cannot do any useful work until 

they have reconnected to an operational scheduler. 

 

2.  As a second stage, the user should place the Secondary Server Backup platform into a Master role. 

This should only be allowed to proceed if there is no operational connection to the previous Master. 

The Secondary Server Backup platform entering a Master role must start its J2EE, scheduler, and 

scanner components. It should attempt to check in any existing Licences from the Licence persistence 

file (i.e., from the previous Master). It should checkout Licences, and then enter an operational role 

and honor connection requests from the other components on its own and other platforms. It will then 

be scheduling and managing jobs using the currently synchronized database and jobs filestore. 

 

3. After the first stage of a Master platform failure all remaining components and clients will be 

attempting to repeatedly reconnect with their configured primary and secondary configuration. After 

the second stage with an operational new Master, they should succeed in remaking this connection 

resulting in a new operational system with whatever components are still functional. 

 

 

Automatic Failover operation 

As an optional configuration an automated detect and failover process may be activated. It is 

recommended that the manual process be used where possible as being simpler and more 

straightforward. The automated process is intended for configurations that are unattended. 

 

Failover Trigger  

1. The Secondary Server Backup platform is the platform responsible for detecting a reason to initiate 

Automatic failover. 

2. When operating as a Secondary Server Backup platform, it should attempt to check the JBOSS 

component on the Master platform every 30 seconds. If successful then the Secondary Server Backup 

platform remains in its back up role and continues to monitor the Master platform in the same way. 

3. If the Secondary Server Backup platform detects the JBOSS has stopped on the Master server, then it 

should retry 10 times at 30 second intervals to make this connection before initiating a Failover trigger. 
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If any of these attempts succeeds, then the Secondary Server Backup platform reverts to normal 

monitoring. 

 

Automatic Failover Action 

1. When a Secondary Server Backup platform triggers automatic failure, then it should first attempt to 

issue a remote shutdown of the application processes on the existing Master platform. If this fails, then 

it should attempt to issue a complete platform shutdown on the Master platform. These steps try to 

ensure that there are no components left running on the Master that might interfere with successful 

operation. 

2. The Secondary Server Backup platform should then initiate automatically a role swap to Master 

Platform just like in the manual procedure. Components on its platform and other remaining 

platforms will reconnect to the new Master automatically. 

  

IntelliTune Grace Period 

A system can go into grace period unexpectedly for one of several reasons. The procedure for diagnosing it is as 

follows: 

 

To Check the license 

 

Check the expiry date and options of the license from the Launcher menu. If no options are present, 

reinstall the license file. If it is expired, a new license is required. 

 

To Check the Wibu Driver 

 

Open WIBU-KEY item in the Windows Control Panel, and check the about box. If there is no WIBU-

KEY entry, re-install the driver from the install disk. 

 

To Check the dongle 

 

Using the WIBU-KEY item in the Windows Control Panel, check the serial number for the dongle, as 

displayed in the Contents tab. This serial number is also written on the dongle itself.  If there is no 

serial number, the dongle is defective. A new one must be obtained within the grace period. 

 

To Check that the correct dongle and license file are being used 

Both the dongle and license file (*.alf) must match the MAC address of the PC. The alf file is in XML 

format. Open it in a text editor, or XML viewer (such as Internet Explorer). 

 

Obtain the MAC address of the PC by running: 

 

ipconfig /all 
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from the command line. The MAC address is referred to as the Physical Address. Check that this 

matches the HardwareKey entry in the alf file. Check that the dongle serial number (written on the 

dongle) matches thenSerialNr entry in the Dongle section of the alf file. 

 

NOTE: The MAC address will change if a new network card is installed in the PC, and the dongle and 

license will then cease to work. 

 

 

NOTE: The MAC address can also change if the PC is switched between VPN and non-VPN access 

(under VPN it acquires a virtual MAC address). 

  

Interface to :Arkitex 

9.2 LogViewer 

 

This document describes the interface between IntelliTune  Arkitex LogViewer. To install LogViewer, refer to 

the Import Events Setup section in the LogViewer User Guide (CG+0949710001). 

 

NOTE: Set the filter in the Import Events Setup to .csv.  

 

Interface Overview 

1. When the LogViewer interface is enabled, IntelliTune will periodically write out event log files to a 

specified folder in LogViewer CSV format. 

2. The folder must be local to the IntelliTune server PC. IntelliTune will accumu- late events for a short 

period (e.g., 60 seconds), then write out a new log file containing all the events that occurred during 

that period. If no events occurred, no log will be generated. 

3. It is the responsibility of LogViewer to remove the files when they have been read. 

 

Setting up the Interface 

 The interface is configured by editing the CSV Logging in System Prefeences 
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120 of 

140 
:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 

 

  

HQ - Thousand Oaks, California :Arkitex Enhance Intellitune  Family Installation Guide 

9.3 Interface to Arkitex BonderExt 

This document describes the interface between IntelliTune and Arkitex BonderExt. 

IntelliTune / Arkitex BonderExt 

The Arkitex BonderExt service provides a method to interface from a Producer TCP/IP socket to IntelliTune 

input folders. The IntelliTune System Preferences needs to opened to enable the creation of the Intellitune.xml 

status file. 

 

9.4 Installing Producer to External Applications Interface 

 The External Applications Interface is a plug-in available in Producer located on the Arkitex Workflow 

Installation DVD. 

  

Enabling the Arkitex Status Option 

1. Launch IntelliTune 

2. Select Start 

3. Click on all taxk 

4. Start Client after all task are started 

5. Login to Client 

6. Select System Preferences Icon 
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7. Select XML Status 

8. Click on XML Status Enabled 

9. Default Folder is XML Status Folder C:\Arkitex 

10. Number of Status Files is 1 to 24 

11. Leave other settings set to default settings 

 

 

 

12. Insert the Arkitex Workflow Products DVD into your DVD-ROM drive. 

 

 

  



122 of 

140 
:ARKITEX ENHANCE INTELLITUNE FAMILY INSTALLATION GUIDE 

 

  

HQ - Thousand Oaks, California :Arkitex Enhance Intellitune  Family Installation Guide 

1. At the Arkitex Workflow splash screen, select the Workflow button. 

2. Select Arkitex Producer. 

 

 

 

3. When the Welcome dialog box is displayed, select Next to continue. 
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1. At the License Agreement screen, accept the terms. Click Next. 

 

 

 

2. To accept the default path, select Next. 

 

 

NOTE: You may use the default location or you may use Browse to create a new path and file name. Either 

way, you will be given the choice to create a new folder. 

  

 

 

3. Uncheck Producer and Producer Server 

4. Check Producer to External Application. Click   
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5.  At the Start Copying Files screen, click Next. 

  

 

 

6.  The Setup Status screen will displays for awhile. 
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7. At the Bonder Services screen, highlight the BonderExt service name, then click Edit. 

 

 NOTE:  After upgrading to IntelliTune/OptiInk System v4 (or above) then the :Arkitex to External 

Applications Service (BonderExt.exe) may stop accepting data. This is because the required 

MonitoredExe data value needs to be changed. The old MonitorExe data value was Launcher2W.exe 

which needs to be changed to javaw.exe 
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8. At the Bonder Parameters screen, change the defaults as follows. Then click OK. 

9. At the Bonder Services screen, click Exit 

 

 

 

10. Click Finish 

11. Type: BonderEXT -service 

12.  Enter your ArkitexService logon name and password 
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13. Default settings: 

14. Logon name: ArkitexService 

15. Password: !AgfaService1 

16. Confirm password: !AgfaService1 

17. Browse to the \Arkitex status folder. 

18. Browse to your default :IntelliTune/OptiInk drop folder root. 

19. Enter  javaw.exe. Click OK. 

20. Click OK. At the Bonder Services screen, click Exit. 
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Edit the BonderExt registry as follows: 

1. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Autologic\Bonder\BonderExt. 

 

 

 

2.  Set the value for AppendIdToFileName to 0. 

3.  Create a new REG_DWORD called UsePageSetupForSubDir, and set the value to 1. 

4. If UsePageSetupForSubDir=1 and ItxDefaultFolder is not an empty string, the page setup name in the 

logical device will be appended to the drop folder. 

5.  If UsePageSetupForSubDir=1 and ItxDefaultFolder is an empty string, the page setup name in the 

logical device will be used as the full path for the drop folder. 

6. If UsePageSetupForSubDir=0, then the value of the ItxDefaultFolder registry entry is used. 

7. Create your logical devices in Producer where the PageSetup must match the input folder name in 

IntelliTune/OptiInk. 
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To Verify Bonder is running as a Service 

1. To verify that bonder is running as a service, go to Administrative Tools >Services. 

2. Open the Services icon, and locate :Arkitex to External Device in the list. 

 

 

 

How to Manually Registering the BonderExt Service 

If you ever have to manually register bonder as a service, you will use the command window. 

To Register the Service 

1. Open a command window. 

2. Locate the BonderEXT.exe file.  

3. cd :\Arkitex\Producer\bin <ret>  

4. Type in the following command: bonderEXT.exe -regservice 

5. The window will show that the StartServiceCtrlDispatcher has been called. 

6. Now type in this command 

7. bonderext.exe service 

8. When the service is successfully registered, the command window will display that bonder was 

installed. 

9. At he command prompt, enter services.msc to display the Services window 

10. Verify that Bonder appears in Services 

 

Run as an Application for Debugging 

If you ever need to troubleshoot bonder, you can activate debugging mode. 
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To Enable Debugging 

 

1. Open a command window. 

2. Locate the bonderEXT.exe file. 

3. cd :\Arkitex\Producer\bin <ret> 

4. Type in the following command: 

5. bonderEXT -UnregServer 

6. When the service is successfully unregistered, the following will display in the command window. 

7. Bonder service removed 

 

 

8. Type in the following command: 

9. bonderEXT –NoService 

10. This runs as a console application for debugging 
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9.5 Interface to Arkitex Analyst 

The following specifies how to configure IntelliTune to feed data to Arkitex Analyst for reporting. 

1. Open System Preferences 

 

 

2. To enable Text Reporting click on box to enable by entering a check.  This will enable the InkSave.txt 

file 

To enable XML Reporting click on box to enable by entering a check. Creates a folder where the XML 

files will be stored when jobs are processed. These files are used by Analyst to create reports 

3. Click Apply then OK to exit System Preferences 

 

Modify Output Workflow 

The Ink Save Calculator must be activated in the Output workflow. 

Enable INK Mode 

1. Create or Open an Output operation. 

2. Ink Report: Will prepare the colour managed source file, render both source and result and perform 

an ink save calculation. 

3. Select Ink Report 

 

 

4. Max speed: Will optimise performance by doing the minimum rendering and no preparation of colour 

managed source files. 

5. Fast Edit: Will prepare the colour managed source file at the same time as processing the result but 

will do extra rendering. 

6. Check Embed Profile 

7. Use Output Profile 
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To Configure Output 

 

8. Image  Filetype – default is original 

 

 

9. Image Compression 

 

 

10. PDF Compression -  ITX or OptiInk 

 

 

11. Select the PDF Compression Method. 

 

 

 

12. Drag the slider until you reach the desired value for Jpg Quality. 

13. Check CMYK jpg saved as CMYK, if necessary. 

14. Check Byte Order as MacIntosh, if necessary. 
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15. Bit Depth select 8 the default, Same as Input or 16 

 

 

 

16. To apply a File Name Mask, enter it in the Mask value box. 

17. Check EPS ASCII, if necessary 

18. Check EPS Preview Tiff, if necessary 

19. Check Read PS Jpeg Resolution, if necessary. 

20. Check Read Exif Jpeg Resolution, if necessary. 

21. Check Use Exif Orientation, if necessary. 
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22. Check Save IPTC 

23. Check EXIF 

24. Check the Make Thumbnail check box. A thumbnail preview is saved together with your image. 

The Make thumbnail control when enabled will require a render of the result file independent of the 

Ink Mode control. 

25. Check Crop Before Analyze 

26. Or click on Select Profile click on The Choose box and select Pofile 

27. Set the output operation in the desired workflow. 

 

Modify Color management 

28. Select Color Management in Workflow you selected 

29. Click on Use Output Profile  
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Modify User Preferences 

1. Launch OptiInk, and log in. 

2. Open Tools > User Preferences, and check Display detailed Ink Save Values. 

 

 

3. Click OK. 
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Modify Workflows 

1. Select the Workflows tab. 

2. Select one of the existing workflows, or create a new workflow. 

3. Locate the GCR operation, and verify that Apply GCR is enabled. 

 

4. The PDF operation should already be added to the workflow. Make any changes as needed. 
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Process a PDF File 

1. Process a PDF file in the desired hot folder. 

2. Select Details view > Ink > Saved %. 

  

 

 

3. Select Details View or List View. Ink savings will appear as Saved %. 

Details View 

 

 
… 

 List View 
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Verify Location of XMLInkReports Folder 

 

1. Locate the folder XMLInkReports where specified in System Preferences 

2. Open one of the XML files. 

3. Additional information has been added, Original path, pagecount, image count  

 

 

  

 

Configure Arkitex Analyst 

1. Set up Arkitex Analyst to monitor applications to generate reports by configuring the 

AnalystAgentSettings.properties. Input folders and parsing rules are defined. 

2. AnalystAgentSettings.input folder8=\\Analyst_Input_OptiInk or Intellitune  

3. AnalystAgentSettings.parsingrule8= OPTIINK or INTELLITUNE 

4. The XML files must be placed in the defined Input folder to generate Product Summary and Complete 

Page Flow Reports. 

Pseudo Grace Credit and Protection 
 

1. Pseudo Grace is a mechanism that allows operation of the application if the standard ELMS Licensing 

system is unavailable for some reason. E.g. if the ELMS service is on another platform and this is 

turned off, crashes or is unreachable. It is important to recognise that it  does not apply if the ELMS 

system is available even if that system is in Grace or has Grace expired or there is some other licence 

problem. 

2. It works on a system of credit hours. Credit builds up slowly whilst the system is operating normally in 

a non-graced ELMS environment. Credit only starts building up when a system has been on for at least 
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3 hours and will build up to a maximum of 14 days. This credit is maintained if the application is 

stopped or shutdown. 

3. Under the conditions where ELMS is unreachable then the system will remain operational operating in 

a pseudo-grace mode and the credit will decrease accordingly at the rate of 1 minute for each minute 

of operation. If all pseudo-grace credit is used up the system will stop. 

4. If the system goes into pseudo-grace then measures should be taken as soon as possible to investigate 

why ELMS cannot be reached and corrected. 

 

 

 


